Error in NS 2.5 HelloWorld app


#1

I try run Helloworld app from http://docs.nativescript.org/angular/tutorial/ng-chapter-1 . and get Error: Exception: The plugin tns-android@2.5.0 is already installed

ISSUE: https://github.com/NativeScript/nativescript-cli/issues/2487


#2

It is a known issue that occurs sometimes, and is a bit annoying.

To fix it you need to edit your package.json's content and remove the tns-android dependency under "dependencies: { }", as well as the android entry from the "nativescript: { }" key if one was also written there. Then clear the npm cache npm cache clear and proceed with installing the platform again - tns platform add android


#3

delete it
thanks.
works fine


#4

Hi ! I have the same problem and I do what you suggest, I delete from package.json the tns-android but when I tried to add android platform it throws me

sed: invalid replacement string

Do you have any idea for this?

Thanks a lot !