ENOENT: no such file or directory.... project.pbxproj

ios

#1

Hi everyone,
I hope someone can help us with this issue.

We created a nativescript-vue project using a Mac (We had some issues creating the project on windows and then running it on mac), then with a windows computer branched off and developed on each our system. Everything worked great, after some work we merged the “mac branch” into the “windows branch”. Everything works smoothly on Android for both platforms after the merging however, iOS does not want to run anymore and we get the following error:

Successfully prepared plugin nativescript-theme-core for ios.
Successfully prepared plugin nativescript-vue for ios.
Successfully prepared plugin tns-core-modules for ios.
Successfully prepared plugin tns-core-modules-widgets for ios.
Unable to apply changes on device: 2A74BE30-4EE6-419F-9F95-BD2EACEB8E6C. Error is: ENOENT: no such file or directory, open ‘/Users/minhturi/Downloads/test-way/way-mobile/dist/platforms/ios/dist.xcodeproj/project.pbxproj’.

We use the following dependencies:
“dependencies”: {
“nativescript-geolocation”: “^4.2.6”,
“nativescript-google-maps-sdk”: “^2.6.0”,
“nativescript-plugin-firebase”: “^6.4.0”,
“nativescript-stripe”: “^3.2.1”,
“nativescript-theme-core”: “^1.0.4”,
“nativescript-vue”: “^1.3.1”,
“tns-core-modules”: “~3.4.1”,
“vue-router”: “^3.0.1”,
“vuex”: “^3.0.1”
}

What we have tried so far, but with the same error…
Strip away all dependencies that are added by us later and everything except the bare minimum from main.js.
Reset the iOS simulator.
Uninstall and install nativescript -g
tns remove and add ios
tns update

tns doctor indicates all is well, and we are able to run tns run ios --log trace without any problems.

Any suggestions are appreciated! If you need more info, let me know.


#2

If anyone else encounters this issue, we somehow got it to work by pulling the branch again and doing this:
npm uninstall nativescript -g
npm cache clean --force (This step was added from previous trial).
npm install nativescript -g


#3

I’ve got exactly the same error after running “npm run clean” and trying to use “npm run watch:ios” again. I couldn’t solve it with the above solution. :confused: Also re-installing node_modules didn’t help. The dependency versions haven’t changed.

It also doesn’t matter if I use the simulator or a real device. “tns doctor” says all is fine.

Any idea?

Edit: I could fix it by removing all files under /template, except for the /app folder and package.json file. No idea why, but it works…


#4

Hey @danielb
I haven’t tested this yet, but one thing I noticed now later is that we did run “tns add ios” before we got the error and now as it works there is not any stuff about tns-ios in template/package.json. You could try “tns remove ios” in the template folder and run it from root with “npm run debug:ios” as it adds the ios part when you run it.


#5

I ran into the same thing and came across this post. A simple restart fixed this issue for me. I’d suggest trying that first!