Emulator won't run application (Stuck at Refreshing Application)


#1

Hi there, I am just getting started with Nativescript. I went through the tutorial and got the app to connect to my emulator once. After stopping the app and coming back to it later, tns run android seems like it’s working, but then just stops at “Refreshing Application”.

This is the log thats printed to the console…

Skipping prepare.
Searching for devices...
Skipping package build. No changes detected on the native side. This will be fast!
Installing...
Successfully installed on device with identifier 'emulator-5554'.
Transferring project files...
Successfully transferred all files.
Refreshing application...

and it just stops there and does nothing…

My emulator is up and running on port 5554

Is there any way to debug what is happening at this point to figure out why it isn’t booting up my app? Would I have to debug this on the emulator? Or could it be a tns issue?

tns version : 2.5.4
Cross-platform modules : tns-core-modules@2.5.0

I can’t find any of the recommended info to share when posting a question. Hopefully this is enough info for someone to point me in the right direction.
Thanks in advance!
-Greg


#2

@smithygreg you could run tns run android --log trace to get additional logs about the operations going behind the scenes.


#3

When this happens I usually resolve the issue by shutting down the emulator and firing it back up.


#4

Well, it’s working now. Honestly not sure precisely what fixed it.
Am I supposed to have the emulator running before I “tns run android” or should I let tns start the emulator?
The time it worked now I let tns start it.

Thanks!