Emulator Very Slow


#1

Hi–the iOS emulator is running very slow for me.

I run $ tns run ios, and then the terminal setup runs fine. But then when the emulator opens its as if everything on the emulator is in slow motion. All actions are in slow motion, including not just the app I am running but also other items on the emulator, such as going into settings.

This may well not be because of a nativescript flaw–maybe a Mac OS issue or an Xcode issue. But I am not sure where to look to solve. All software on the system is up to date, and I have tried restarting already.

Has anyone else experienced this?

MacOS High Sierra v 10.13.5
NS v 4.1.0


#2

When you say emulator… do you mean the MacOs XCode Simulator?

Runs fine here with the same specs you have

Per this: https://stackoverflow.com/questions/31378232/xcode-simulator-animations-extremely-slow-when-played-in-editor

Try command+T?


#3

Thanks–Yes, I don’t think this is a wide-ranging bug, but a problem specific to my system. I am talking about the xcode simulator (the thing that runs when you run $ tns run ios).

Could be that I accidentally activated some kind of slow animations, but where do you (and stackoverflow) mean for me to run command+T? I am running the emulator out of my terminal / NS CLI. So hitting command+T in the terminal just opens a new terminal shell window.


#4

I got it!

Thanks very much for your help @sitefinitysteve .

My emulator (ie, iOS simulator) was indeed running slow because “slow animations” had somehow been turned on.

To solve, I clicked on the simulator, and then Debug >> slow animations (uncheck slow animations).

Back to normal now. Thanks again.