Create app for android 4.1


#1

Hello everyone, is there any way you can create an app with native script for android devices with 4.1.1 operating system?


#2

you can try with command cli:

tns platform add android[@] --sdk[–sdk ] (an integer designating the api level that the application targets).

https://docs.nativescript.org/docs-cli/project/configuration/platform-add


#3

That’s not possible as the runtime’s minimum requirement is API Level 17 / 4.2.
Source: https://docs.nativescript.org/runtimes/android/requirements

Roughly there are 2% of devices still running 4.1 and earlier so it may not affect your user base.
Source: https://developer.android.com/about/dashboards/


#4

good afternoon, thanks for the information unfortunately the only cell that I have for testing is 4.1.1, so I think at the moment I would not be able to use it :frowning: