CocoaPods could not find compatible versions for pod "Firebase"


#1

Hi, I’ve been getting started using NativeScript-Vue and nativescript-plugin-firebase. When running npm run watch:ios I get this error.

[!] CocoaPods could not find compatible versions for pod "Firebase":
  In Podfile:
    Firebase (~> 2.5.0)

Specs satisfying the `Firebase (~> 2.5.0)` dependency were found, but they required a higher minimum deployment target.
CocoaPods could not find compatible versions for pod "FirebaseCore":
  In Podfile:
    Firebase/Core (~> 5.1.0) was resolved to 5.1.0, which depends on
      Firebase/CoreOnly (= 5.1.0) was resolved to 5.1.0, which depends on
        FirebaseCore (= 5.0.2)

    Firebase/Core (~> 5.1.0) was resolved to 5.1.0, which depends on
      FirebaseAnalytics (= 5.0.1) was resolved to 5.0.1, which depends on
        FirebaseCore (~> 5.0)
Unable to apply changes on device: BE4B4EE0-253F-4812-8CBB-E17BB6DE95F4. Error is: Command pod failed with exit code 1 Error output: 
 
[!] Automatically assigning platform `ios` with version `8.0` on target `dist` because no platform was specified. Please specify a platform for this target in your Podfile. See `https://guides.cocoapods.org/syntax/podfile.html#platform`.

I tried to update the podfile’s minimum deployment target but I cannot find a podfile anywhere within my project. Any ideas? Thanks in advance.


#2

Did you try updating your local pod repo?

pod repo update


#4

Yes I have run that but it did not solve the issue, thanks