Cloud Build completed, Failed to Install ipa (no reason given)

ios

#1

Has anyone had the cloud build process complete all the way to the file load and then fail? Error is simply “Could not install application”. Latest releases, IOS on iPhone X.

[18-08-05 16:47:28.546] (CLI) The result of cloud build of ‘/Users/keith/ns/d18’, platform: ‘iOS’, configuration: ‘Debug’, buildId: 43781bf8-3fbb-4863-8d00-f3116900b978 successfully downloaded. OutputFilePath: /Users/keith/ns/d18/.cloud/ios/device/d18.ipa

[18-08-05 16:47:28.796] (CLI) Installing…

[18-08-05 16:48:06.808] (CLI) Unable to apply changes on device: 8b7279bd0c5349cb46d2bbbc1495266cc0993de6. Error is: Failed to install /Users/keith/ns/d18/.cloud/ios/device/d18.ipa on device with identifier 8b7279bd0c5349cb46d2bbbc1495266cc0993de6. Error is: Could not install application.

[18-08-05 16:48:06.812] Error detected during LiveSync on 8b7279bd0c5349cb46d2bbbc1495266cc0993de6 for /Users/keith/ns/d18. Error: Failed to install /Users/keith/ns/d18/.cloud/ios/device/d18.ipa on device with identifier 8b7279bd0c5349cb46d2bbbc1495266cc0993de6. Error is: Could not install application

[18-08-05 16:48:06.817] Stopped LiveSync on 8b7279bd0c5349cb46d2bbbc1495266cc0993de6 for /Users/keith/ns/d18.

[18-08-05 16:48:06.825] (CLI) Executing after-watch hook from /Users/keith/ns/d18/hooks/after-watch/nativescript-dev-typescript.js

[18-08-05 16:48:06.825] (CLI) Stopping tsc watch

[18-08-05 16:48:06.825] (CLI) Executing after-watch hook from /Users/keith/ns/d18/hooks/after-watch/nativescript-dev-webpack.js


#2

Is it a Dev / AdHoc certificate you used, did you make sure the device is registered and add to that certificate / provisional?


#3

I viewed TJ’s video several times. When I PUBLISH from Sidekick on Windows, with the deployment certificate and provisioning profile, after a minute or so Sidekick asks me to log onto my Apple Developer Account. Yes, I paid for it. As soon as I enter my Email and password on SideKick/ immediately I mean, on my Mac appears a message asking first by location if this attempt is ok. I accept it. Then my MAC gives me a six digit code.

No place to enter this code in SideKick. I’m at a loss as to how to proceed. Trying now to get SideKick to run on my Mac. No joy there yet either. Any help appreciated.


#4

The method that should work is Apple’s app specific passwords. This allows third party software, such as SideKick to access itunes connect with revealing the basic user’s AppleID password. Actually a pretty good thought.

As of this writing I can tell you that the app specific password doesn’t work with Sidekick. Sidekick returns a 401 error that the Apple ID and Password provided doesn’t match. I tried
http://www.applicationloader.net/blog/en/90.html and it failed with the same error message.

At this time I don’t imagine running Sidekick to publish on a Mac would have a different result.

So I updated my Mac XCODE and Published through the failure on SideKick on my Windows machine then moved the .ipa file to my Mac and, following this: https://help.apple.com/itc/apploader/#/apdATD1E927-D1E1A1303-D1E927A1126 I was able to upload my Nativescript application to the Apple Store.

Now, it’s odd but true that Apple’s own AppLoader is considered 3rd party software and it did require an app specific password. That worked! Weird, but it worked.

So until Sidekick uses the xxxx-xxxx-xxxx-xxxx app specific password, which, by the way, bypasses the two-factor authentication, it seems my work around is the only choice.

Good luck!


#5

The cert and provisioning profile were for deployment and I believe that provisioning for deployment doesn’t utilize the uuid’s. App specific passwords should work though, in Sidekick. Two factor authentication on the app store is a fact.