Can't publish app on appstore


#1

can’t publish app on appstore, here is screen:


#2

I have faced similar error previously…
Have you run this command before archive ?
tns build ios --bundle --env.uglify --env.aot --release --forDevice --provision ProvisioningProfileID


#3

no I just run: tns build ios


#4

I’m not sure the CLI should copy those binary files over from node_modules to tns_modules, but as @pap5508 mentioned it’s probably a good idea to remove any non-used code by bundling your app.


#5

I run: tns build ios --env.uglify --env.aot --release --forDevice --provision ProvisioningProfileID

witout --bundle because when i put --bundle on it its not building it gaves me error,
without --bundle build is succeeded but still getting same error when try to upload app on appstore.

please help.

I’m using natievscript core with dev-webpack plugin installed

error when building with --bundle is:
TypeError: Cannot read property ‘emit’ of undefined
at NativeScriptWorkerPlugin.exports.NativeScriptWorkerPlugin.NativeScriptWorkerPlugin.apply


#6

I would suggest Open Xcode > click on left top corner Xcode > preferences > location > click on DerivedData arrow icon which opens in new tab… > force quit Xcode. > delete Derived Data folder from tab > try once again with tns build ios --bundle --env.uglify --env.aot --release --forDevice --provision ProvisioningProfileID


#7

I just removed dev-webpack plugin and worker-loader plugind and then just build: tns build ios --for-device --release --provision ProvisioningProfileID and it works now, Thanks