Cannot build/run in android after updating to NS 4.2


#1

Hi!

So after I updated my packages to the new version of Nativescript I bumped into an issue during run/build.

Here’s the error I got:

and my updated package.json:

"dependencies": {
    "@angular/animations": "~4.2.4",
    "@angular/common": "~4.2.4",
    "@angular/compiler": "~4.2.4",
    "@angular/core": "~4.2.4",
    "@angular/forms": "~4.2.4",
    "@angular/http": "~4.2.4",
    "@angular/platform-browser": "~4.2.4",
    "@angular/platform-browser-dynamic": "~4.2.4",
    "@angular/router": "~4.2.4",
    "nativescript-angular": "^4.2.0",
    "nativescript-background-http": "^3.0.0",
    "nativescript-camera": "^3.0.1",
    "nativescript-ngx-fonticon": "^2.2.3",
    "nativescript-plugin-firebase": "^4.0.5",
    "nativescript-telerik-ui": "^3.0.4",
    "nativescript-theme-core": "~1.0.4",
    "nativescript-toasty": "^1.1.5",
    "reflect-metadata": "~0.1.8",
    "rxjs": "~5.3.0",
    "tns-core-modules": "next",
    "zone.js": "^0.8.2"
  },
  "devDependencies": {
    "babel-traverse": "6.9.0",
    "babel-types": "6.10.0",
    "babylon": "6.8.1",
    "filewalker": "0.1.2",
    "lazy": "1.0.11",
    "nativescript-dev-android-snapshot": "0.*.*",
    "nativescript-dev-typescript": "^0.3.1",
    "shelljs": "^0.7.0",
    "tslint": "^4.5.1",
    "typescript": "~2.3.2"
  }

Nativescript Cli v3.1.3
tns-core-modules@next: 3.2.0

For what I could find there are different uncompatible versions in the generated AndroidManifests.

This stackoverflow post is related: https://stackoverflow.com/questions/43280871/android-getting-manifest-merger-failed-error-after-update-to-new-version-of-grad

Any help would be appreciated.
Thanks!

Edit:
So I’ve rollbacked to my previous version of package.json and I still have the same problem, so I guess it’s the cli causing this issue?

Edit2:
Not the cli, the problem is with the firebase plugin, I’ve created new projects and installed firebase with updated packages and I can reproduce the issue. Without firebase it does not occur.
To replicate:

  • I’ve used Sidekick to create a Drawer template with Angular.
  • Run vanilla and everything went good.
  • Installed nativescript-firebase-plugin@4.0.5
  • Copied my config files to new project
  • Run and got the same error as described above.
    I’ve already opened an issue in the plugins github, but if anyone is aware of any solution I would be very thankful.

#2

It was fixed by applying the compileSdk argument to 25 when running/building. (–compileSdk 25)