Build error when changing the icon image?


#1

I am trying to change my icon and launch screen on my NativeScript app (iOS). I fixed all the icons sizes and copied them into the AppIcon.appiconset with the exact same names, but when I try to run it, it fails to build. I have done the same exact change on the Groceries app and it worked. I literally copied and pasted my set of icons to the AppIcon.appiconset file in the Groceries app and it worked. I dont know if it is a dependency issue.
Here is the Building log:

bash-3.2$ tns run ios --emulator
Skipping prepare.
Searching for devices…
Building project…
Build settings from command line:
ARCHS = i386 x86_64
CODE_SIGN_IDENTITY =
CONFIGURATION_BUILD_DIR = /Users/ingen2/Sitefinity/SF-V_Check/VSCode_NativeScript_App/platforms/ios/build/emulator
ONLY_ACTIVE_ARCH = NO
SDKROOT = iphonesimulator10.2
SHARED_PRECOMPS_DIR = /Users/ingen2/Sitefinity/SF-V_Check/VSCode_NativeScript_App/platforms/ios/build/sharedpch
VALID_ARCHS = i386 x86_64

=== BUILD TARGET VSCodeNativeScriptApp OF PROJECT VSCodeNativeScriptApp WITH CONFIGURATION Debug ===

Check dependencies

PhaseScriptExecution NativeScript\ PreBuild build/VSCodeNativeScriptApp.build/Debug-iphonesimulator/VSCodeNativeScriptApp.build/Script-C
97FD7AC1ADE5369004DB2A4.sh
cd /Users/ingen2/Sitefinity/SF-V_Check/VSCode_NativeScript_App/platforms/ios
/bin/sh -c /Users/ingen2/Sitefinity/SF-V_Check/VSCode_NativeScript_App/platforms/ios/build/VSCodeNativeScriptApp.build/Debug-iphones
imulator/VSCodeNativeScriptApp.build/Script-C97FD7AC1ADE5369004DB2A4.sh
/bin/sh: /Users/ingen2/Sitefinity/SF-V_Check/VSCode_NativeScript_App/platforms/ios/build/VSCodeNativeScriptApp.build/Debug-iphonesimulat
or/VSCodeNativeScriptApp.build/Script-C97FD7AC1ADE5369004DB2A4.sh: Permission denied

** BUILD FAILED **

[11:50]
The following build commands failed:
PhaseScriptExecution NativeScript\ PreBuild build/VSCodeNativeScriptApp.build/Debug-iphonesimulator/VSCodeNativeScriptApp.build/
Script-C97FD7AC1ADE5369004DB2A4.sh
(1 failure)
Command xcodebuild failed with exit code 65

run ios

┌─────────────────────────────────────────────┬─────────────────────────────────────────────────────────────────┐
│ Usage │ Synopsis │
│ Run on all connected devices │ $ tns run ios [–release] [–justlaunch] │
│ Run on a selected connected device │ $ tns run ios [–device ] [–release] [–justlaunch] │
│ Start an emulator and run the app inside it │ $ tns run ios --emulator [] [–release] │
└─────────────────────────────────────────────┴─────────────────────────────────────────────────────────────────┘

Runs your project on a connected iOS device or in the iOS Simulator, if configured. This is shorthand for prepare, build and deploy. Whi
le your app is running, prints the output from the application in the console and watches for changes in your code. Once a change is det
ected, it synchronizes the change with all selected devices and restarts/refreshes the application.

IMPORTANT: Before building for iOS device, verify that you have configured a valid pair of certificate and provisioning profile on your
OS X system.

[11:50]
W

Options

  • –no-watch - If set, changes in your code will not be reflected during the execution of this command.
  • –device - Specifies a connected device on which to run the app.
  • –emulator - If set, runs the app in a native emulator for the target platform, if configured. When set, you can also set any othe
    r valid combination of emulator options as listed by $ tns help emulate ios. You cannot use --device and --emulator simultaneously.
  • –release - If set, produces a release build. Otherwise, produces a debug build.
  • –justlaunch - If set, does not print the application output in the console.
  • –clean - If set, forces rebuilding the native application.

Attributes

  • is the index or name of the target device as listed by $ tns device ios
  • is any valid combination of options as listed by $ tns help emulate ios

#2

Hi @MajdSoufan, maybe the following line gives you a hint on what could be wrong:

tns can not access the script because the permissions are not set correctly.
I have to confess that I am guessing with my answer, but the error message is pretty clear. If you copied something from location A to B then this could cause the shown problem by owning wrong permissions.

Kind regards, David