Boot / Debug issues

nativescriptcore

#1

Hi everybody!

Just started my first Native + Angular project… Seems great!

But I’m facing a big issue: tns debug (here for android platform) takes nearly 15min to complete… I guess this is not normal.

From the begining “Skipping prepare” step takes at least 5min…

Everytime a change is detected, rebuilding app takes again several minutes (12…?)
A lot of waring or errors are displayed in console before (like xml syntax error in node_modules/bla bla…"

Executing before-prepare hook from <myapp>\hooks\before-prepare\nativescript-dev-typescript.js Hook skipped because either bundling or livesync is in progress.
Preparing project...
 .....<myapp>\app\node_modules\json-schema\draft-zyp-json-schema-03.xml has syntax errors.
error
entity not found:&rfc2045;
....

Any clue? is this “normal” ??

Thx

Salvo


#2

So not a single reply ^^

Wow…

Salvo.


#3

That’s absolutely not normal, it takes a few seconds to recompile during live sync.

Did you add json-schema module as dependency?


#4

Hi manojdcoder!

Thank for your reply…

I did not… I mean, I didn’t add this dependecy myself.

I already tried the following procedure:

  1. rm -rf node_modules
  2. tns platform remove android
  3. tns platform add android
  4. tns debug android --device <my_device>

-> Same error, same duration…

Here the previous error has raised and aar plugin dependecies have been added(TNSSideDrawer, TNSCode, TNSChart) then…
image

Salvo.


#5

Can you try to find why json-schema is being added in your project, you might able to find it from package-lock.json


#6

npm install -i adds it automatically…

It seems to be used by “angular-cli” dep. which I uninstalled…

Errors are not raised anymore -> good point.

But not any faster now… :frowning:

Salvo


#7

Ok, I’ve reinstalled everything and… it takes now less than 1min.

Sadly… it now crashes on “:app:packageDebug” step: