App Transport Security override not working


Hi all,

I’ve added the following code to my app’s info.plist file in order to enable the app to communicate with my server.





Problem is, as soon as I try to a build with Sidekick, Nativescript changes the plist file back to what it was and excludes the part I added - meaning my app presents the error saying that "The resource could not be loaded because the App Transport Security policy requires the use of a secure connection.

Can anyone advise what I’m doing wrong? I need this to work and am falling behind on my deadline trying to get this working. I’ve Googled the initial bit but not seen anything regarding Nativescript removing the additions to the file just before building the app.


This looks like a Sidekick issue, @TodorTotev Is it possible to edit these settings in SideKick?


I seem to have solved this, hopefully, or at least found a work around.

I not only updated the info.plist under /platforms/ios//app/App_Resources/iOS/Info.plist I also updated the one in the /app/App_Resources/iOS/Info.plist folder as I think Sidekick was copying that one across into the version in platforms. Once I did that it worked perfectly.


You are supposed to update only the app/App_Resources/iOS/Info.plist, that is the one part of your project. Anything inside platforms folder is auto generated (complied) ones.


That’s funny because last night I read a post that stated you must edit the one in platforms.

See my remark in another post about me being an amateur - thankfully people like you exist to help me out :slight_smile:

Although never mind then, I’m happy to have it correct now.