'App' Has Stopped Working


#1

I have created a test app using the Nativescript CLI, via tns create testNativescript --ng, and everything seems to be ok. I add the android platform, and I am using Genymotion as the emulator. I run tns run android --emulate and it builds the app, puts it on genymotion, but the app on the emulated device does not run. Screen shot: https://imgur.com/a/ZzDXw

The console doesnt show any errors:https://imgur.com/a/bRSb7

Versions of Software:
Genymotion- 2.9.0. the image is 7.1.0 API 25 - 2.9.0
Nativescript- - 3.1.2
Typescript - 2.4.2
Node- 6.9.2
Android APIs- 23,25,26 with images for intel and google
Android Home PATH- C:\Users\myuser\AppData\Local\Android\android-sdk
Android Images - C:\Users\myuser\AppData\Local\Android\android-sdk\system-images

I dont know what is missing or how to fix/debug the issue. Any help in debugging is greatly appreciated!


#2

In these rare cases the android device’s log will have the stack trace. Run your app, let it fail, adb logcat -d > log.txt and share in a pastebin.


#3

Here is the pastebin link: https://pastebin.com/ru6NJSJD

I am not sure if I did this correctly, but I went to the Android platform-tools dir and ran the adb command you mentioned, but it just ran and stopped. Is it supposed to do that?


#4

Thank you for the log - yes, that is indeed what the -d flag of adb logcat will do, it dumps its entire buffer. If you’d like to read it continuously as data is logged adb logcat is the only thing you run.

Back on topic - I did not find anything out of the ordinary from those logs, well besides the fact that the runtime comes crashing down before it has managed to initialize. Please zip the big bulky project directory (yes, that includes node_modules and platforms), and send it my way via PM, I’d be interested in investigating this matter further.


#5

Ok. I sent you over the files requested via PM.


#6

Had the same issue, in my case no memory was available (found it by looking in the logcat, thanks!)