Android sdk problems after update


#1

Dear Nativescript-Community,

I have problems getting the latest version of NativeScript (2.5.2) to work with the latest version of android-studio/android-sdk.

As you can see in the log file ( Log at pastebin ) tns doctor is not able to find an appropriate targetSdk (Cannot find a compatible Android SDK for compilation) even though i installed a bunch of them. It seems like it is trying to use the android command in sdk/tools but this command is not available anymore.

Any suggestions how to get this thing running? Environment variables are set and before updating android and nativescript (from 2.4) everything worked very well. I also tried to reinstall nativescript but it didn’t help.


#2

Have you updated your android libs/sdks locally? Run android from terminal and update the build-tools and support/design libs for sure.


#3

i updated them via android-studio and thus i can’t run android in terminal, because the command does not exist anymore. issue 2583 (meanwhile i created an issue on that)


#4

Hello I’m running into the same issue, i reinstalled all that i could
I’m an android developer
Thank you very much !


#5

You can check out this issue for a solution and to see when/if this’ll be fixed.


#6

Did the same, had the reinstall. Have not updated android studio since that incident.