"aidl is missing" Problem

android

#1

Hello there, community. I’m new here. I have a problem that need to be solved.

This is the first time I use NativeScript. I followed the installation guide, installed everything. But when I tried to run or build, I always got “aidl is missing” problem. Is there any solution to fix this? I have been looking for the solution on the internet but no luck.

Thank you for the help.


#2

Are you sure, you installed all required platform apis and build tools for Android?


#3

Yes, I guess. tns doctor shows no issue.

Build Tools


#4

API


#5

Bump. No solution? :confused: There are no problems with my Android Studio and even React Native can build APK for my device flawlessly. The build only works with Sidekick cloud build but it’s very limited to use (only 100 for free user).


#6

Hi @ilhamscahya
Can you try following this video
https://youtu.be/Qc-1Cq5UAIQ

Let us know if that fixes the problem for you


#7

Hello, there. Thank you for the reply. Take a look on my module settings. It’s very weird.

image

When I change It into something, my project will get an “invalid argument” error. BUT, when I try to run the project via Android Studio, not via NativeScript CLI (tns run android), without editing the module settings, It will works fine without “aidl is missing” error. :tired_face::sob: