Accepting incoming network connections after saving XML (debugger attachment)


#1

Hello,

Ever since I started to work with {N} I keep getting the “Do you want application X to accept incoming network connections” dialog. I was somewhat ok with it so far, but now that my workflow includes constant modifications to XML file(s), it is getting annoying.

I only get this popup if I modify and save XML file(s). I don’t get these if I save js files. When I save XML files and this popup happens, the console shows the following output:

NativeScript debugger attached.
CONSOLE LOG file:///app/tns_modules/tns-core-modules/inspector_modules.js:1:82: Loading inspector modules...
CONSOLE LOG file:///app/tns_modules/tns-core-modules/inspector_modules.js:6:12: Finished loading inspector modules.

So it seems modifying and saving XML files causing the debugger keep attaching for some reason, and that triggers the “Do you want application X to accept incoming network connections” to happen, even though I am not doing any debugging.

This has nothing to do with actually allowing the incoming network connection, and adding the app to the Firewall settings in the “Security & Privacy” setting under OS X preferences. Every time I create a new app, regardless how small or empty it is, it is being added to the Firewall list (to allow the connection), but the popup still asking me if I want to allow the connection when I save an XML file. I have also added Xcode at some point to the Firewall list (just to see if it helps), but that didn’t help either.

Anyone came across this and have a solution?

Thanks.

OS X 10.11.6 (El Crapitan)
Xcode 8.2.1

(I use this version of Xcode because this is the last version that is compatible with El Crapitan, and since I only have an iTouch 5G which cannot be upgraded beyond 9.3.5, this is the Xcode I can use. Upgrading Xcode would mean I have to upgrade my OS and do all sorts of tricks to build for my iTouch - and I’m not interested doing all that.)


#2

Whoa, 30 views so far! I must be the only one with this issue.


#3

As I think you’ve noticed, this is an OS X bug, not really a NativeScript issue. Just searching for that message returns hundreds of reported conflicts around it.

Things people have mentioned as solutions:

  1. Disable your Firewall Security
  2. Turn off “Share my library” in your iTunes preferences (no clue how this is related)
  3. Alter node configuration with Firewall (lots of people upvoted this: https://github.com/tj/n/issues/394#issuecomment-312510914)

#4

I am aware that generally “Do you want X to accept incoming network connections…blah blah” is happening all over the Mac ecosystem. I would not have asked this question on this forum if the console messages I’m getting would not be coming from {N}.

  1. That is not a good idea
  2. I never had sharing enabled in iTunes
  3. I don’t have node “n” installed

And since I’m only getting this when I {N} debugger is getting attached AND when I save XML files (even though I’m not starting the debugger), I figured this might has to do something with {N} somehow.

It’s survivable. Just really annoying.